Bimmerpost
3
&
4 Series
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2019+ BMW 3 AND 4-SERIES FORUMS (G2x Generation) Local Forums UK Harman Kardon niggles

Post Reply
 
Thread Tools Search this Thread
      01-10-2021, 07:34 AM   #89
Beemer5to3
Second Lieutenant
81
Rep
275
Posts

Drives: G30 520d SE
Join Date: Jun 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Well after another visit to the dealer, I was told eventually that they could identify the fault. The bad news is that it requires a new amplifier, but said amplifier isn't available yet and they can't tell me when I'll get one. That on top of various other issues I've had with the car means I'm now going down the rejection route. Shame really, as the G20 is a cracking car when all is working well. It's full of bugs though, and as a very loyal BM owner I have to say this will be my last in a while.
While BMW UK look at my case, I'm considering my options (and none of them have a blue and white roundel on the front).

Will keep everyone updated as to what happens.
That's not true, they can order it. It's 1100 quid for the dealer ( non refundable) and it takes 5 days from Germany.

Ring the parts department your self and find out availability.
Part number is 65 12 5 A38 AB8
Thanks for this.

Apparently it's a new part, as in a completely new amp they're using now because of faults with the old one, and it's not available in stock yet.
Appreciate 0
      01-10-2021, 07:47 AM   #90
davidoff86
Major
429
Rep
1,004
Posts

Drives: M40i
Join Date: Apr 2015
Location: UK

iTrader: (0)

Quote:
Originally Posted by Beemer5to3 View Post
Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Well after another visit to the dealer, I was told eventually that they could identify the fault. The bad news is that it requires a new amplifier, but said amplifier isn't available yet and they can't tell me when I'll get one. That on top of various other issues I've had with the car means I'm now going down the rejection route. Shame really, as the G20 is a cracking car when all is working well. It's full of bugs though, and as a very loyal BM owner I have to say this will be my last in a while.
While BMW UK look at my case, I'm considering my options (and none of them have a blue and white roundel on the front).

Will keep everyone updated as to what happens.
That's not true, they can order it. It's 1100 quid for the dealer ( non refundable) and it takes 5 days from Germany.

Ring the parts department your self and find out availability.
Part number is 65 12 5 A38 AB8
Thanks for this.

Apparently it's a new part, as in a completely new amp they're using now because of faults with the old one, and it's not available in stock yet.
Yes, the part number I provided is the new replacement, that's been available since the start of December. People are having it installed and fixing this issues:

See this post :

https://g20.bimmerpost.com/forums/sh...8;postcount=12
Appreciate 1
      01-10-2021, 08:00 AM   #91
Beemer5to3
Second Lieutenant
81
Rep
275
Posts

Drives: G30 520d SE
Join Date: Jun 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Well after another visit to the dealer, I was told eventually that they could identify the fault. The bad news is that it requires a new amplifier, but said amplifier isn't available yet and they can't tell me when I'll get one. That on top of various other issues I've had with the car means I'm now going down the rejection route. Shame really, as the G20 is a cracking car when all is working well. It's full of bugs though, and as a very loyal BM owner I have to say this will be my last in a while.
While BMW UK look at my case, I'm considering my options (and none of them have a blue and white roundel on the front).

Will keep everyone updated as to what happens.
That's not true, they can order it. It's 1100 quid for the dealer ( non refundable) and it takes 5 days from Germany.

Ring the parts department your self and find out availability.
Part number is 65 12 5 A38 AB8
Thanks for this.

Apparently it's a new part, as in a completely new amp they're using now because of faults with the old one, and it's not available in stock yet.
Yes, the part number I provided is the new replacement, that's been available since the start of December. People are having it installed and fixing this issues:

See this post :

https://g20.bimmerpost.com/forums/sh...8;postcount=12
Thanks so much for this - really helpful. I'll get a note across to BMW UK tomorrow. Cheers
Appreciate 0
      01-12-2021, 08:21 AM   #92
Jackrack
Enlisted Member
15
Rep
49
Posts

Drives: BMW 330e
Join Date: Oct 2019
Location: Leicester

iTrader: (0)

Quote:
Originally Posted by Beemer5to3 View Post
Thanks so much for this - really helpful. I'll get a note across to BMW UK tomorrow. Cheers
Have a read back of a few pages too, BMW replaced my amp and fixed all the issues above.

Cheers
Appreciate 0
      01-12-2021, 12:23 PM   #93
Beemer5to3
Second Lieutenant
81
Rep
275
Posts

Drives: G30 520d SE
Join Date: Jun 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by Jackrack View Post
Quote:
Originally Posted by Beemer5to3 View Post
Thanks so much for this - really helpful. I'll get a note across to BMW UK tomorrow. Cheers
Have a read back of a few pages too, BMW replaced my amp and fixed all the issues above.

Cheers
Yeah I saw that - thanks. They've acknowledged there's a fault and needs a replacement amp, but the dealer said it wasn't available to order and couldn't tell me when it could be fixed.

It's in the hands of BMW UK now anyway, so I'm just waiting to hear back now.
Appreciate 0
      01-13-2021, 03:37 AM   #94
Jackrack
Enlisted Member
15
Rep
49
Posts

Drives: BMW 330e
Join Date: Oct 2019
Location: Leicester

iTrader: (0)

Quote:
Originally Posted by Beemer5to3 View Post
Yeah I saw that - thanks. They've acknowledged there's a fault and needs a replacement amp, but the dealer said it wasn't available to order and couldn't tell me when it could be fixed.

It's in the hands of BMW UK now anyway, so I'm just waiting to hear back now.
I guess some dealers have some in stock waiting, others need to order in. What a pain.

Third world problems, we all know but annoying nonetheless!

Good luck
Appreciate 1
      01-22-2021, 07:51 AM   #95
Beemer5to3
Second Lieutenant
81
Rep
275
Posts

Drives: G30 520d SE
Join Date: Jun 2020
Location: UK

iTrader: (0)

Update as of today:

I've got my car back following the replacement of the Amp - so far so good! Will be giving it a few days to make sure all ok, but it definitely seems to sound a bit better than it did, so hopefully that's the problem solved (fingers crossed!)
Appreciate 0
      01-22-2021, 09:45 AM   #96
johnboysafc
Private First Class
johnboysafc's Avatar
United Kingdom
44
Rep
161
Posts

Drives: BMW G20 330e MSport Xdrive
Join Date: Sep 2020
Location: Cumbria, England

iTrader: (0)

Garage List
Quote:
Originally Posted by Beemer5to3 View Post
Update as of today:

I've got my car back following the replacement of the Amp - so far so good! Will be giving it a few days to make sure all ok, but it definitely seems to sound a bit better than it did, so hopefully that's the problem solved (fingers crossed!)
Yeah hope it's done the trick
__________________
JohnBoySAFC
Appreciate 0
      01-22-2021, 10:01 AM   #97
davidoff86
Major
429
Rep
1,004
Posts

Drives: M40i
Join Date: Apr 2015
Location: UK

iTrader: (0)

Quote:
Originally Posted by Beemer5to3 View Post
Update as of today:

I've got my car back following the replacement of the Amp - so far so good! Will be giving it a few days to make sure all ok, but it definitely seems to sound a bit better than it did, so hopefully that's the problem solved (fingers crossed!)
Excellent, of course i'm still waiting for the same part to arrive at my dealers. It was in stock, but then out of stock when they went to order it!


next week apparently
Appreciate 0
      01-22-2021, 12:46 PM   #98
Beemer5to3
Second Lieutenant
81
Rep
275
Posts

Drives: G30 520d SE
Join Date: Jun 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Update as of today:

I've got my car back following the replacement of the Amp - so far so good! Will be giving it a few days to make sure all ok, but it definitely seems to sound a bit better than it did, so hopefully that's the problem solved (fingers crossed!)
Excellent, of course i'm still waiting for the same part to arrive at my dealers. It was in stock, but then out of stock when they went to order it!


next week apparently
Hope you manage to get it sorted soon. I think it's now becoming a more well-known fault, so I'm willing to bet there's a lot of people like us who've had to live with it for a few months until BMW Technical played catch up, and therefore a waiting list for the part!
Appreciate 0
      01-22-2021, 01:01 PM   #99
davidoff86
Major
429
Rep
1,004
Posts

Drives: M40i
Join Date: Apr 2015
Location: UK

iTrader: (0)

Quote:
Originally Posted by Beemer5to3 View Post
Quote:
Originally Posted by davidoff86 View Post
Quote:
Originally Posted by Beemer5to3 View Post
Update as of today:

I've got my car back following the replacement of the Amp - so far so good! Will be giving it a few days to make sure all ok, but it definitely seems to sound a bit better than it did, so hopefully that's the problem solved (fingers crossed!)
Excellent, of course i'm still waiting for the same part to arrive at my dealers. It was in stock, but then out of stock when they went to order it!


next week apparently
Hope you manage to get it sorted soon. I think it's now becoming a more well-known fault, so I'm willing to bet there's a lot of people like us who've had to live with it for a few months until BMW Technical played catch up, and therefore a waiting list for the part!
They were meant to have ordered it before I posted the puma case stuff for you, but they didn't get ruound to it lol !
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:14 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST