Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2019+ BMW 3 AND 4-SERIES FORUMS (G2x Generation) General G20 Sedan / G22 Coupe / G26 Gran Coupe Discussions Comfort Access stopped working

Post Reply
 
Thread Tools Search this Thread
      08-10-2019, 03:34 AM   #1
lausc
New Member
5
Rep
13
Posts

Drives: BMW G20 320i
Join Date: May 2019
Location: Hong Kong

iTrader: (0)

Comfort Access stopped working

I have had my car for 5 days now. Everything is perfect except for the comfort access feature. For the first few days, I was able to use it without any problem. The car would lock itself as I walk away and unlock when I approach. It then suddenly stopped working and I had to open the doors by grabbing the handles. But today even grabbing the handles won't do the trick!! I tried grabbing all four handles but none of them would unlock the car. Only grabbing the handles on the passenger side would lock the car and the handles on the driver side doesn't seems to do anything at all. After reading around on the internet I have tried resetting iDrive, using my spare key and storing my key in the other pocket away from my iPhone. Unfortunately none of that worked. Anyone else experienced this? I really enjoyed the car but this issues really bothers me. If all else fails I will take it in to the dealer to see if they can fix it.
Appreciate 0
      08-10-2019, 01:45 PM   #2
hockeymen14
Private First Class
90
Rep
119
Posts

Drives: 07' 328i e90 sport package
Join Date: Nov 2015
Location: Gulfport, FL

iTrader: (0)

Quote:
Originally Posted by lausc View Post
I have had my car for 5 days now. Everything is perfect except for the comfort access feature. For the first few days, I was able to use it without any problem. The car would lock itself as I walk away and unlock when I approach. It then suddenly stopped working and I had to open the doors by grabbing the handles. But today even grabbing the handles won't do the trick!! I tried grabbing all four handles but none of them would unlock the car. Only grabbing the handles on the passenger side would lock the car and the handles on the driver side doesn't seems to do anything at all. After reading around on the internet I have tried resetting iDrive, using my spare key and storing my key in the other pocket away from my iPhone. Unfortunately none of that worked. Anyone else experienced this? I really enjoyed the car but this issues really bothers me. If all else fails I will take it in to the dealer to see if they can fix it.
Did you check the settings in idrive to see if they were reset and correct? Are you using the same key linked to the same profile? Everything you are describing is customizable. If settings in idrive are right and linked to your profile and you're using the right key then you either have a software glitch or a serious hardware issue.
Appreciate 0
      08-10-2019, 09:47 PM   #3
mzdial
Second Lieutenant
mzdial's Avatar
United_States
74
Rep
211
Posts

Drives: '19 G20 330i & '19 G01 X3
Join Date: Oct 2013
Location: Zionsville, IN

iTrader: (0)

Garage List
Quote:
Originally Posted by lausc View Post
I have had my car for 5 days now. Everything is perfect except for the comfort access feature. For the first few days, I was able to use it without any problem. The car would lock itself as I walk away and unlock when I approach. It then suddenly stopped working and I had to open the doors by grabbing the handles. But today even grabbing the handles won't do the trick!! I tried grabbing all four handles but none of them would unlock the car. Only grabbing the handles on the passenger side would lock the car and the handles on the driver side doesn't seems to do anything at all. After reading around on the internet I have tried resetting iDrive, using my spare key and storing my key in the other pocket away from my iPhone. Unfortunately none of that worked. Anyone else experienced this? I really enjoyed the car but this issues really bothers me. If all else fails I will take it in to the dealer to see if they can fix it.
When I had my 330i in a week and a half ago, this was an issue that I brought up with my SA. BMW is aware of it and there is not a fix yet at this time. They suggested disabling the auto lock/unlock to keep it from happening for the time being.

I'd like to say that this is first-year bugs, but I've had BMWs for the past 20+ years and quirks sometimes never completely get fixed.
Appreciate 1
      08-11-2019, 01:34 AM   #4
lausc
New Member
5
Rep
13
Posts

Drives: BMW G20 320i
Join Date: May 2019
Location: Hong Kong

iTrader: (0)

Quote:
Originally Posted by hockeymen14 View Post
Did you check the settings in idrive to see if they were reset and correct? Are you using the same key linked to the same profile? Everything you are describing is customizable. If settings in idrive are right and linked to your profile and you're using the right key then you either have a software glitch or a serious hardware issue.
Yeah I have been using the same profile and key all along. I also did not change the settings after I set it on day 1. I will bring it in to see if the dealer can do anything about it.
Appreciate 0
      08-11-2019, 10:58 AM   #5
gpdriver17
First Lieutenant
153
Rep
333
Posts

Drives: F90 M5
Join Date: Jul 2019
Location: Bay Area

iTrader: (0)

I've been having the same issue. It works sometimes, usually it doesn't.
Appreciate 0
      08-13-2019, 06:24 AM   #6
rajens00
Private
United_States
32
Rep
59
Posts

Drives: 2019 330xi
Join Date: Dec 2012
Location: Michigan

iTrader: (0)

Garage List
Quote:
Originally Posted by gpdriver17 View Post
I've been having the same issue. It works sometimes, usually it doesn't.
I discovered that if you use the key Fob to lock the doors then the auto unlock feature will not work. However if you use the comfort access door handle touch to lock the doors or the automatic lock when you walk away feature then the automatic unlock as you approach does work.
Appreciate 0
      08-13-2019, 10:34 AM   #7
NeroCCC
New Member
2
Rep
13
Posts

Drives: 2020 M340 Xdrive
Join Date: Aug 2019
Location: USA

iTrader: (0)

I been experience the same issue. I think if you turn the smart access on and you also using handle or key button to lock/unlock the car, the car will gets confused and don't know what to do. What I did is re-check this smart access again in idrive, and let car power down for a while and retry them again, so it will cycle the power to reboot.
Appreciate 0
      08-13-2019, 12:44 PM   #8
lausc
New Member
5
Rep
13
Posts

Drives: BMW G20 320i
Join Date: May 2019
Location: Hong Kong

iTrader: (0)

Quote:
Originally Posted by rajens00 View Post
I discovered that if you use the key Fob to lock the doors then the auto unlock feature will not work. However if you use the comfort access door handle touch to lock the doors or the automatic lock when you walk away feature then the automatic unlock as you approach does work.
Thanks. This way the unlock by approach seems to work. But the lock when leaving never worked.
Appreciate 1
      08-13-2019, 03:28 PM   #9
DonTheDon
New Member
12
Rep
23
Posts

Drives: M340i, 340, mustang
Join Date: Jun 2019
Location: California

iTrader: (0)

Quote:
Originally Posted by lausc View Post
Thanks. This way the unlock by approach seems to work. But the lock when leaving never worked.
Yeah using the fob breaks it. To make it work again, put your finger on the door to lock and walk away (after setting up the options in i drive again). After that it should work! Disable and enable them. Worked for me when i got mine at least
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:34 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST