Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Technical Topics iDrive, Nav, Phone, Audio, Video, Cameras, Electronics "Driver Assistance support reduced" error message

Post Reply
 
Thread Tools Search this Thread
      03-08-2019, 04:50 PM   #1
ksd4aadg
New Member
United_States
3
Rep
11
Posts

Drives: 2019 BMW 330 M Sport
Join Date: Mar 2019
Location: Los Angeles

iTrader: (0)

"Driver Assistance support reduced" error message

I got my 330 M Sport 3 weeks ago. Love the car but from the get go, 'Driver Assistance Support Reduced' error would continuously flash on my nav screen. See picture attached. It'd usually last a few minutes and it'd fix itself. I brought the car in for repair and they upgraded the system and sent me home. The error continues to pop up more and more and I've scheduled another service. Anyone else running into this? Super annoying and a hassle after 3 weeks living with this car. I checked the X5 forum and sounds like it's common problem with the Kafas camera. I guess I should have expected this with the systems being so new.
Attached Images
 

Last edited by ksd4aadg; 03-08-2019 at 04:51 PM.. Reason: More info
Appreciate 0
      03-08-2019, 05:21 PM   #2
cangenBMW
Enlisted Member
Canada
19
Rep
31
Posts

Drives: BMW 330i xDrive
Join Date: May 2016
Location: Western Canada

iTrader: (0)

This has been a pretty common issue with the new G05 X5 as well. Seems there was a bad batch of KAFAS cameras and the fix is to have the whole sensor array replaced. It may also be that the sensors are dirty/obstructed but considering how covered this topic is on the G05 forum I'm guessing it's a faulty camera array.

https://g05.bimmerpost.com/forums/sh....php?t=1573619
Appreciate 0
      03-08-2019, 06:11 PM   #3
jmg
Major General
jmg's Avatar
United_States
7764
Rep
9,023
Posts

Drives: F80 M3 CS, I01 i3 REx LCI
Join Date: Mar 2013
Location: Orange County, CA

iTrader: (0)

Garage List
The Kafas system isn't new to BMW, it's been in the F30 and I01 i3 for years. Most probably a bad batch. I've had mine replaced in the i3 before, not a big deal so long as they fix the problem with the hardware.
__________________
2018 F80 ///M3 CS - Lime Rock Grey Metallic | MPHAS | GC Camber Plates
2019 I01 i3 BEV - Giga World
Previous: F80 M3 | I01 i3 Rex LCI | I01 i3 REx | F30 340i M Sport ZTR | F30 328i Sport | Audi B7 S4 25Quattro #33 of 250 | E21 320i
Appreciate 0
      03-09-2019, 02:54 AM   #4
ADS-UK
Captain
ADS-UK's Avatar
United Kingdom
456
Rep
988
Posts

Drives: G30 - 530d M Sport
Join Date: Feb 2014
Location: Edinburgh, Scotland

iTrader: (0)

Garage List
Doesn't that show what the affected system is? In my G30, it usually points to either radars or KAFAS
Appreciate 0
      03-09-2019, 12:53 PM   #5
ksd4aadg
New Member
United_States
3
Rep
11
Posts

Drives: 2019 BMW 330 M Sport
Join Date: Mar 2019
Location: Los Angeles

iTrader: (0)

When I select 'Affected Systems', it shows Lane Departure warning and Frontal Collision warning. I turned off the lane departure warning feature. So far no warnings after a day. We'll see if this is does the trick until they get it fixed.
Appreciate 0
      03-11-2019, 07:29 AM   #6
mbanck
Private First Class
85
Rep
173
Posts

Drives: Skoda Karoq
Join Date: Sep 2018
Location: Munich, Germany

iTrader: (0)

Quote:
Originally Posted by jmg View Post
The Kafas system isn't new to BMW, it's been in the F30 and I01 i3 for years. Most probably a bad batch. I've had mine replaced in the i3 before, not a big deal so long as they fix the problem with the hardware.
The G20 has a new(ish?) KAFAS high camera though, see posts #3 and #4 of https://g20.bimmerpost.com/forums/sh....php?t=1589218

This one might have some initial issues, dunno.
Appreciate 0
      03-13-2019, 11:42 PM   #7
ksd4aadg
New Member
United_States
3
Rep
11
Posts

Drives: 2019 BMW 330 M Sport
Join Date: Mar 2019
Location: Los Angeles

iTrader: (0)

Got the car back from the dealer after the second visit. They're ordering the camera and they think it'll be in by the end of March. Hopefully the second camera fixes this. We'll see.
Appreciate 0
      04-18-2019, 01:15 AM   #8
bking604
New Member
6
Rep
7
Posts

Drives: 2019 330 M sport
Join Date: Apr 2019
Location: Vancouver

iTrader: (0)

I have the same problem for my 2019 330 as well, but all my in-car sounds will also malfunction when the "driver assistance support reduced" error shows up. Does it happen to yours?

Here is a video of what I'm talking about:
https://www.youtube.com/watch?v=W82EMiF9pZ4
Appreciate 0
      04-18-2019, 12:10 PM   #9
ksd4aadg
New Member
United_States
3
Rep
11
Posts

Drives: 2019 BMW 330 M Sport
Join Date: Mar 2019
Location: Los Angeles

iTrader: (0)

I only had the driver assistance reduced error issue. It would come on mostly for a few minutes whenever I drove the car. The error would disappear after a few minutes. I brought the car in twice for reprogramming before they determined to replace the kafas camera entirely. The part took a month before it arrived and they installed it 2 days ago. So far so good. Crossing my fingers that it's been resolved. The dealer said she had a new X5 with the same issue since it's the same camera and technology. If you go over to the X5 forum, there's a similar thread. I attached pictures of the invoice regarding the work. Hopefully you can share with the dealer. My bluetooth also stopped working for a week and it came back on magically right before I dropped the car off. It's been reprogrammed and seems to be working fine. Love the car but man it's tough being the guinea pig.
Attached Images
  
Appreciate 1
      04-18-2019, 10:44 PM   #10
bking604
New Member
6
Rep
7
Posts

Drives: 2019 330 M sport
Join Date: Apr 2019
Location: Vancouver

iTrader: (0)

Thanks for the info. I'll show them to my dealer and see what they say. I guess something else is causing the sound malfunction. Weird thing is the sound and driver assistance error always go together, and never one or the other.

Quote:
Originally Posted by ksd4aadg View Post
Love the car but man it's tough being the guinea pig.
This is exactly how I feel...
Appreciate 0
      04-22-2019, 05:35 AM   #11
Chimpysan
Registered
0
Rep
3
Posts

Drives: BMW 330i 2019
Join Date: Feb 2019
Location: Fl

iTrader: (0)

Got exactly same issue with my G20 about a month ago. I really do think this is the known issue for the current camera system. I took G20 to dealer here in west palm beach and they told me camera got issues, so they replaced it and reprogrammed. Now it works totally fine.

On the other hand my '19' x3 also has bluetooth problem. It keeps disconnecting my phone, didn't bring it to dealer yet.
Appreciate 0
      04-23-2019, 12:55 AM   #12
claykin
Brigadier General
United_States
553
Rep
3,288
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by Chimpysan View Post
Got exactly same issue with my G20 about a month ago. I really do think this is the known issue for the current camera system. I took G20 to dealer here in west palm beach and they told me camera got issues, so they replaced it and reprogrammed. Now it works totally fine.

On the other hand my '19' x3 also has bluetooth problem. It keeps disconnecting my phone, didn't bring it to dealer yet.
BMW revised the KAFAS part number beginning 4/2019 production.

http://www.realoem.com/bmw/enUS/show...diagId=66_0504
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      05-14-2019, 09:09 PM   #13
markdk
Registered
2
Rep
4
Posts

Drives: 2019 BMW 330i MSport
Join Date: May 2019
Location: Georgia

iTrader: (0)

I've seen the "reduced driver assistance" error at least 5 times in the 6 weeks I've had the car (330i M Sport). I lose everything electronic; nav, com, music, camera's. From the posts above all of this is related to a camera issue? It's an hour drive to the dealer, but looks like i have do what i have to do. Pretty frustrating. My first BMW and otherwise love the car.
Appreciate 0
      05-19-2019, 05:06 PM   #14
CyclingBroStyle
Private First Class
CyclingBroStyle's Avatar
United_States
102
Rep
165
Posts

Drives: '19 330i xDrive M Sport
Join Date: Sep 2014
Location: Washington, D.C.

iTrader: (0)

Garage List
same issue going to the dealer this weekend... slightly annoyed
__________________
Current: MY2019 330i xDrive M-Sport w/Lasers - Portimao Blue
Previous: MY2013 328i xDrive Sport Line - Sapphire Black | MY2016 428i xDrive M-Sport - Mineral Grey
BMW CCA #522637 use me as a referral for BMW CCA
Appreciate 0
      05-31-2019, 04:23 PM   #15
DomiGijzen
Private First Class
DomiGijzen's Avatar
Netherlands
52
Rep
178
Posts

Drives: BMW 320d (G20)
Join Date: Apr 2019
Location: Netherlands

iTrader: (0)

Having this warning too. Did you also experience black screens in the cockpit? As in a reboot. It comes back quick but everything aside the bare minimum (gas, brake, steer and shift) stops for a few seconds. And, I had it every few minutes for a couple of hours. You?

Dealer did a reset and scheduled an update. as it seems, every test they tried ended with update required.
They are also surprised that my dash shows an x3 while starting up. What does your dash show? Back then, sales guy told me this was an known issue and would be fixed by a ota update.
__________________
Grz D.!
Appreciate 0
      12-10-2019, 11:56 AM   #16
BMV///M3
Captain
BMV///M3's Avatar
277
Rep
977
Posts

Drives: BMW f80 M3
Join Date: May 2012
Location: CA

iTrader: (1)

Gonna bump this thread. We took delivery on 8/10/19 and have had this problem a least 6 times. I had the software update from 4/2019 to 11/2019 and its still doing it, though carplay works better. Taking it in next week. I talked to my SA about KAFAS system but they will have to test it. I've also seen it could be the RAM (reciever audio module? Radio
Appreciate 0
      12-15-2019, 03:50 PM   #17
simonbt
New Member
0
Rep
12
Posts

Drives: BMW 330i M Sport Plus (G21)
Join Date: Dec 2016
Location: UK

iTrader: (0)

Bump on this thread again!

I took delivery of a 330i M Sport Touring (G21) last week and I've seen this error pop up twice already

It was in very heavy rain so could have simply been that, but will keep my eye on it now!
Appreciate 0
      12-15-2019, 10:32 PM   #18
BEK46
New Member
United_States
0
Rep
24
Posts

Drives: 2019 BMW 330 x-drive
Join Date: Apr 2019
Location: St. Charles IL

iTrader: (0)

I've had this happen occasionally after driving in snow or slush, especially in colder weather. The system resets when the front camera and sensors are cleared.
Appreciate 0
      12-17-2019, 08:33 PM   #19
MurrayB
New Member
United_States
5
Rep
23
Posts

Drives: 2020 BMW M340ix
Join Date: Dec 2018
Location: EasternPA/SouthernNJ

iTrader: (0)

I had the same issue warning flashing two separate times the day I took delivery of the M340ix, last Friday. The car was parked for about four hours after the first first warning the camera lens must have dried and when I went out after about an hour in rain it flashed again. Fine since.

Bad design of the sensor and layout. At least from reading the forum I knew what it was when it happened. Otherwise, I would have probably freaked out.
Appreciate 0
      12-20-2019, 02:28 PM   #20
eddiehaug
Private
Norway
48
Rep
96
Posts

Drives: 330e G20
Join Date: Oct 2018
Location: Norway

iTrader: (0)

My car was produced in November, and I've also seen this message, but it only appeared after the visibility got affected by rain/snow, so I understand the cameras and sensors are not to trust. For me it makes sense —if the car cannot guarantee your security, better to warn you about it.

Not that this is everybody's issue, but I think that's the reason I see the message at least.
__________________
Country: NO
Software version: 11/2019
Maps version: 4/2019
Appreciate 0
      12-20-2019, 07:31 PM   #21
Pacman123
Private
24
Rep
87
Posts

Drives: Mazda 3 , BMW M340i Xdrive
Join Date: Oct 2019
Location: PA

iTrader: (0)

Yeah this happened to me recently when it was raining alot. I found it alarming the first time and annoying the second. The message doesn't seem to go away unless you acknowledge and click close. I find that the worst part
Appreciate 0
      12-20-2019, 09:50 PM   #22
MurrayB
New Member
United_States
5
Rep
23
Posts

Drives: 2020 BMW M340ix
Join Date: Dec 2018
Location: EasternPA/SouthernNJ

iTrader: (0)

We pay for an option that does not work when we need it the most!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:13 AM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST