Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Technical Topics iDrive, Nav, Phone, Audio, Video, Cameras, Electronics CarPlay Delay

Post Reply
 
Thread Tools Search this Thread
      08-22-2020, 11:58 PM   #1
IcEWoLF
Registered
0
Rep
3
Posts

Drives: M340 XDrive
Join Date: Aug 2020
Location: Reno

iTrader: (0)

CarPlay Delay

I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
Appreciate 0
      08-23-2020, 11:32 AM   #2
srbs73
Second Lieutenant
srbs73's Avatar
United Kingdom
86
Rep
200
Posts

Drives: BMW M340i Touring
Join Date: Jun 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by IcEWoLF View Post
I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
Can you try with a different iPhone? If not, I would deleted the phone from the mobile devices, hard reboot the iPhone and pair it again to see if it improves.
Appreciate 0
      08-23-2020, 12:52 PM   #3
902
Private First Class
Canada
133
Rep
108
Posts

Drives: 2020 M340i xDrive
Join Date: Feb 2019
Location: Halifax, Canada

iTrader: (0)

Garage List
Quote:
Originally Posted by IcEWoLF View Post
I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
Do you put your phone on the wireless charger? Does your phone get really warm when that happens? If yes, then the phone is throttling the CPU so it doesn't overheat.
Appreciate 0
      08-24-2020, 09:03 AM   #4
IcEWoLF
Registered
0
Rep
3
Posts

Drives: M340 XDrive
Join Date: Aug 2020
Location: Reno

iTrader: (0)

Quote:
Originally Posted by 902 View Post
Quote:
Originally Posted by IcEWoLF View Post
I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
Do you put your phone on the wireless charger? Does your phone get really warm when that happens? If yes, then the phone is throttling the CPU so it doesn't overheat.
I didn't option for the wireless charger.
I will try and delete the phone and see if it improves things.
Appreciate 0
      08-24-2020, 09:05 AM   #5
Kleev
Private
8
Rep
59
Posts

Drives: BMW 330i
Join Date: Mar 2020
Location: London

iTrader: (0)

Quote:
Originally Posted by IcEWoLF View Post
I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
This is like this for me too. Car play, I change songs in spotify by say pressing the steering wheel control, takes 2 - 3 seconds to change. Annoying to be honest. Should be instant.
Appreciate 0
      08-24-2020, 10:12 PM   #6
mf44
Private First Class
United_States
242
Rep
195
Posts

Drives: 2017 C43
Join Date: May 2019
Location: NY

iTrader: (0)

I know that, in general, wireless CarPlay has a bit of a delay when compared to wired CarPlay. I'm not sure if that's what you're experiencing, but I wonder if you can compare it to another car.
Appreciate 1
      08-25-2020, 06:24 AM   #7
Kleev
Private
8
Rep
59
Posts

Drives: BMW 330i
Join Date: Mar 2020
Location: London

iTrader: (0)

Just to add, for me, when using spotify through the connect BMW standard system, spotify changes instantly. With carplay it's delayed.

I have to say I think prefer using spotify through connect anyway. Works fine.
Appreciate 0
      09-14-2020, 04:35 PM   #8
Peter619
peter619
Peter619's Avatar
United_States
8
Rep
58
Posts

Drives: 2019 330i xDrive
Join Date: Nov 2015
Location: Buffalo, NY

iTrader: (0)

I have an iPhone 11 Pro and I've noticed that after I connect to my 2019 330i, and I try to send a text to 2 people in CarPlay, the automatic first response is "Sorry, there was a problem with the app". After that, I can send a text to those same 2 people but subsequent group texts to different people always results in the same error message on first attempt. It's a real pain because you know that your first text attempt will always fail and you have to do it twice. Does not happen when texting to a single person.

Anyone else experiencing this?
Appreciate 0
      09-16-2020, 06:34 AM   #9
Bris-M340i
Private
Bris-M340i's Avatar
44
Rep
85
Posts

Drives: BMW M340i
Join Date: Jun 2020
Location: Brisbane Australia

iTrader: (0)

Quote:
Originally Posted by IcEWoLF View Post
I have a 2020 BMW M340Ix and I noticed that there is a significant delay with CarPlay when I enter controls, for example if change songs it usually takes 2-3 seconds at least for the system to figure out that I inputted something. Any suggestions?
I have the exact same problem and it is annoying. Maybe itís something to do with the software build. Iím running March 2020, what about you?
Appreciate 0
      09-16-2020, 11:03 AM   #10
randybobandy
Rick James
randybobandy's Avatar
269
Rep
761
Posts

Drives: 2019 BMW X5
Join Date: Oct 2019
Location: USA

iTrader: (0)

I assume this is the same problem, but I cannot stand the beginning of the songs cutting off when changing on carplay. It's a pain in the ass, since I end up hitting the track button again and going back or forward another song!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:56 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST