Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Technical Topics iDrive, Nav, Phone, Audio, Video, Cameras, Electronics Bluetooth - No incoming call sound

Post Reply
 
Thread Tools Search this Thread
      01-19-2020, 03:27 PM   #1
eddiehaug
Private First Class
eddiehaug's Avatar
Norway
103
Rep
195
Posts

Drives: 330e G20 M-Sport
Join Date: Oct 2018
Location: Norway

iTrader: (0)

Has anybody experienced this issue?

I have a Samsung Galaxy S10+, running Android 10. Even though I have made sure I have activated both sound and call sounds via bluetooth, in the phone and the car, when I receive a call the ringtone plays only out of the phone speakers, not the car. Sometimes it doesn't even sound at all.

I don't know if the issue is the car or the phone, but I've tested it with a bluetooth speaker and it works fine, so I tend to think is the car.

I tried unpairing from the phone and deleting from the car, but the issue persists.

Has any of you experienced the same before? Any ideas on how to fix it?
__________________
Car: 330e G20 from 11/2019 (330e G21 xDrive on order)
Country: Norway
iDrive 7 software version: 03.2020.40
Maps version: 2020-3

Last edited by eddiehaug; 01-20-2020 at 01:43 AM..
Appreciate 0
      01-19-2020, 04:28 PM   #2
Quietlife
Private First Class
Quietlife's Avatar
45
Rep
116
Posts

Drives: BMW G20
Join Date: Jun 2019
Location: England

iTrader: (0)

Garage List
2019 BMW G20  [0.00]
I have a Note 8 and downloaded an app called Bluetooth volume manager which solved the issue.
Appreciate 0
      01-20-2020, 02:03 PM   #3
eddiehaug
Private First Class
eddiehaug's Avatar
Norway
103
Rep
195
Posts

Drives: 330e G20 M-Sport
Join Date: Oct 2018
Location: Norway

iTrader: (0)

Quote:
Originally Posted by Quietlife View Post
I have a Note 8 and downloaded an app called Bluetooth volume manager which solved the issue.
Thanks, I tried it today and it didn't help
__________________
Car: 330e G20 from 11/2019 (330e G21 xDrive on order)
Country: Norway
iDrive 7 software version: 03.2020.40
Maps version: 2020-3
Appreciate 0
      01-31-2020, 02:57 AM   #4
StephenJR
Registered
0
Rep
3
Posts

Drives: BMW 330e (G20)
Join Date: Jan 2020
Location: Newcastle

iTrader: (0)

I have just started experiencing the same issue yesterday. Audio is fine for music, and you have full control of calls through iDrive, but there is no sounds for calls. The phone works fine with bluetooth headphones for calls, so assume it must be an issue with the iDrive. Any ideas on how to fix?
Appreciate 0
      02-14-2020, 05:07 PM   #5
Zalamero
Registered
0
Rep
1
Posts

Drives: 2016 BMW 340i
Join Date: Nov 2016
Location: Redondo Beach, CA

iTrader: (0)

I started having the same issue yesterday: no sound for bluetooth calls. I'm able to start a call from the car, but nothing comes through the speakers unless I switch the call to the phone's speaker. I'm able to listen to music from the phone using the bluetooth connection, but anything with a call won't work. I'm using a Samsung Note 9 with Android 10 on it.
Appreciate 0
      02-14-2020, 05:27 PM   #6
StephenJR
Registered
0
Rep
3
Posts

Drives: BMW 330e (G20)
Join Date: Jan 2020
Location: Newcastle

iTrader: (0)

Unfortunately someone has taken a dislike to my car and ripped the rear bumper off. I've told BMW to investigate whilst they have it in th bodyshop. Fingers crossed on a fix 🤞🏼
Appreciate 0
      02-14-2020, 05:37 PM   #7
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1066
Rep
2,210
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Zalamero View Post
I started having the same issue yesterday: no sound for bluetooth calls. I'm able to start a call from the car, but nothing comes through the speakers unless I switch the call to the phone's speaker. I'm able to listen to music from the phone using the bluetooth connection, but anything with a call won't work. I'm using a Samsung Note 9 with Android 10 on it.
I have the exact same issue with my one plus 6T too! Music works fine but calls only via the phone’s speaker and not the car’s. it shows the ongoing call on the Idrive but I have to use the phone’s speaker to hear them.
Wife’s iPhone works perfectly though.

Quote:
Originally Posted by StephenJR View Post
Unfortunately someone has taken a dislike to my car and ripped the rear bumper off. I've told BMW to investigate whilst they have it in th bodyshop. Fingers crossed on a fix 🤞🏼
Ah man. That sucks. Hopefully you get your car back soon enough and they fix the issue while it’s in there.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      02-14-2020, 05:41 PM   #8
StephenJR
Registered
0
Rep
3
Posts

Drives: BMW 330e (G20)
Join Date: Jan 2020
Location: Newcastle

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
I have the exact same issue with my one plus 6T too! Music works fine but calls only via the phone’s speaker and not the car’s. it shows the ongoing call on the Idrive but I have to use the phone’s speaker to hear them.
Wife’s iPhone works perfectly though.



Ah man. That sucks. Hopefully you get your car back soon enough and they fix the issue while it’s in there.
You're telling me. The excitement of a "new" car caught me until I sat in a Lexus and wanted to cry 😪
Appreciate 0
      07-24-2020, 10:08 PM   #9
mohsin88
New Member
5
Rep
13
Posts

Drives: M340i
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by eddiehaug View Post
Has anybody experienced this issue?

I have a Samsung Galaxy S10+, running Android 10. Even though I have made sure I have both sound and call sounds via bluetooth both inside the phone and the car, when I receive a call the sound comes out only of the phone, not the car. Sometimes it doesn't even sound.

I don't know if the issue is the car or the phone, but I've tested it with a bluetooth speaker and it works fine, so I tend to think is the car.

I tried unpairing from the phone and deleting from the car, but the issue persists.

Has any of you experienced the same before? Any ideas on how to fix it?
Someone please guide how should i fixes this issue i am facing same issue with my Android devices i checked with 3 devices ...
Then i connected my brother IPhone which is work completely fine without having any issue please Someone guide me how should i fixe this issue
Appreciate 0
      07-25-2020, 12:05 AM   #10
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
1066
Rep
2,210
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by mohsin88 View Post
Someone please guide how should i fixes this issue i am facing same issue with my Android devices i checked with 3 devices ...
Then i connected my brother IPhone which is work completely fine without having any issue please Someone guide me how should i fixe this issue
I unpaired my phone from the car and removed the car from my phone’s Bluetooth paired settings. I didn’t use Bluetooth for a long time since I was always logging with my JB4 app and didn’t know I could run it in the background while my phone was still connected to the car. Recently paired my phone again with the car and it works fine now. God knows for how long though.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      07-25-2020, 01:16 AM   #11
yaholez
New Member
11
Rep
26
Posts

Drives: 2019 G20 330i
Join Date: Aug 2019
Location: Australia

iTrader: (0)

I'm having the same issue. Had been working fine then suddenly no audio.

This iDrive system is a total joke. Problem after problem.

I contacted BMW and they said it is a known issue after a recent software update on the Android phones. BMW have now included a fix in their most recent software update and have booked me in next week for it.

Hopefully that fixes things.
Appreciate 0
      07-25-2020, 01:39 PM   #12
eddiehaug
Private First Class
eddiehaug's Avatar
Norway
103
Rep
195
Posts

Drives: 330e G20 M-Sport
Join Date: Oct 2018
Location: Norway

iTrader: (0)

Quote:
Originally Posted by yaholez View Post
I'm having the same issue. Had been working fine then suddenly no audio.

This iDrive system is a total joke. Problem after problem.

I contacted BMW and they said it is a known issue after a recent software update on the Android phones. BMW have now included a fix in their most recent software update and have booked me in next week for it.

Hopefully that fixes things.
Can you please let me know how that goes? I'm running 03.2020.40 and the problem persists.
__________________
Car: 330e G20 from 11/2019 (330e G21 xDrive on order)
Country: Norway
iDrive 7 software version: 03.2020.40
Maps version: 2020-3
Appreciate 0
      07-25-2020, 02:32 PM   #13
themnmd
Lieutenant Colonel
themnmd's Avatar
United_States
895
Rep
1,589
Posts

Drives: 2020 M340 i Xdrive
Join Date: Sep 2018
Location: San Rafael CA

iTrader: (0)

S8 no issues no app needed
Appreciate 0
      07-25-2020, 07:43 PM   #14
mohsin88
New Member
5
Rep
13
Posts

Drives: M340i
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by eddiehaug View Post
Can you please let me know how that goes? I'm running 03.2020.40 and the problem persists.
same here bro
It's Frustrating because i have to use Phone speakers while driving
Appreciate 0
      07-28-2020, 07:56 PM   #15
mohsin88
New Member
5
Rep
13
Posts

Drives: M340i
Join Date: Jul 2020
Location: Canada

iTrader: (0)

Quote:
Originally Posted by yaholez View Post
I'm having the same issue. Had been working fine then suddenly no audio.

This iDrive system is a total joke. Problem after problem.

I contacted BMW and they said it is a known issue after a recent software update on the Android phones. BMW have now included a fix in their most recent software update and have booked me in next week for it.

Hopefully that fixes things.
They Updated Mine With 07/2020 but it did not fixed the problem
my Advisor spoke with BMW Canada and now they decided to change the head unit and they will update me tomorrow
Appreciate 1
eddiehaug103.00

      08-22-2020, 03:37 PM   #16
vladarh
Registered
0
Rep
1
Posts

Drives: BMW 330e G20
Join Date: Aug 2020
Location: Norway

iTrader: (0)

Hi,
I'm having the same issue. Has anyone found a solution for this?
Appreciate 0
      08-27-2020, 10:05 PM   #17
Louiss97
Registered
1
Rep
1
Posts

Drives: mazda
Join Date: Aug 2020
Location: United States

iTrader: (0)

It seems this problem happened to many people, I also had the same case with my galaxy note 9, anyone solved this problem yet?
download samsung ringtones free at: Downloadringtonesfree.mobi

Last edited by Louiss97; 09-11-2020 at 05:56 AM..
Appreciate 0
      08-27-2020, 11:19 PM   #18
khine13
New Member
United_States
0
Rep
13
Posts

Drives: 2020 G20 330xi
Join Date: Apr 2019
Location: New England

iTrader: (0)

I've had this issue for awhile now. I unchecked "play phone ringtone" one day and soon after that I got a call and heard the ringtone. I haven't tested recently though.

I do wear a smartwatch which normally attracts my attention enough to answer the call. I have missed calls in the car in the past without the watch connected.

I will test in the AM. This does seem to be a wide spread issue though.

I have a Galaxy Note 9.

BMW does not have a service bulletin for this to claim warranty updates to a newer ID7 version.
Appreciate 0
Post Reply

Bookmarks

Tags
bluetooth, idrive, samsung

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:01 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST