Bimmerpost
3
&
4 Series
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2019+ BMW 3 AND 4-SERIES FORUMS (G2x Generation) Local Forums UK Gesture Control not working

Post Reply
 
Thread Tools Search this Thread
      10-08-2020, 12:27 PM   #1
rodc271
Private
rodc271's Avatar
United Kingdom
17
Rep
68
Posts

Drives: Mineral White 330i M Sport Pro
Join Date: Feb 2020
Location: UK

iTrader: (0)

Enabled Gesture Control in settings and no matter what gestures I try there is no response.

Tried rebooting id7 and full reset, with no change.

Car is Sep 2020 build, so all the latest software.

Any one else had similar issues?
__________________
Mineral White 330i M Sport Pro
Appreciate 0
      10-08-2020, 01:04 PM   #2
Soul_Glo
Major General
Soul_Glo's Avatar
No_Country
7386
Rep
7,157
Posts

Drives: 320d G20
Join Date: May 2013
Location: X

iTrader: (1)

Mine is temperamental. Volume works most of the time but skipping a track does not. I have reset it. Even went as far as disconnecting the battery but no joy. This morning hey bmw stopped working and when it came back on it was so low I could hardly hear it. I'm guessing this is headed toward a software update of sorts from the dealership.
__________________
Just let your soul glo....
Appreciate 0
      10-09-2020, 04:40 AM   #3
Sussex_G20
First Lieutenant
Sussex_G20's Avatar
United Kingdom
135
Rep
373
Posts

Drives: G20 330i M Sport
Join Date: Jun 2014
Location: South Coast - Eastbourne

iTrader: (0)

Plus One here

Volume nearly always seems to work but have given up on all the others. Great for pax to play with.

For track changing I always use the steering wheel controls and the HUD. Have been doing it this way since my 435i in 2014 so maybe haven't given it a proper chance, there again live is too short. Gesture control wasn't one of my key requirements, actually didn't appear in my top 100 either.
Appreciate 0
      10-09-2020, 08:50 AM   #4
Jackrack
Enlisted Member
15
Rep
49
Posts

Drives: BMW 330e
Join Date: Oct 2019
Location: Leicester

iTrader: (0)

I thought they were gimmicky at first but now swear by using it to control volume, and have my 2 own gestures set up for return to home and recognise track being played on radio both which I use alot.

Assume further down the line there will be more and more, one which I thought would be great is a swipe left / right to go back and forwards between pages.

Apologies - not really relating to your topic I would contact sytner and get it booked in should be covered under warranty.
Appreciate 0
      10-09-2020, 12:30 PM   #5
Keith_C
Private
Keith_C's Avatar
United Kingdom
42
Rep
86
Posts

Drives: BMW 330i M Sport Plus
Join Date: Jan 2020
Location: UK

iTrader: (0)

This maybe obvious and completely wrong, but are you gesturing too close to the dash, I usually do it with my elbow on the arm rest as when I 1st got the car it drove me mad as it would only work 1 in 6 attempts or there abouts, so I got in the habit of resting my arm as I was gesturing too close to the dash and it was missing my gestures. During this time, it always picked the volume gesture up, it was just forwarding the tracks and pausing I found difficult to register and now it's 9 times out of 10 it works.
__________________
330i M Sport - Mineral Grey - M Sport Plus - Technology - Premium - Comfort - Visibility - Park Assistant Plus - Fine-Wood trim Oak Grain Open-Pored
Appreciate 0
      10-09-2020, 12:35 PM   #6
rodc271
Private
rodc271's Avatar
United Kingdom
17
Rep
68
Posts

Drives: Mineral White 330i M Sport Pro
Join Date: Feb 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by Keith_C View Post
This maybe obvious and completely wrong, but are you gesturing too close to the dash, I usually do it with my elbow on the arm rest as when I 1st got the car it drove me mad as it would only work 1 in 6 attempts or there abouts, so I got in the habit of resting my arm as I was gesturing too close to the dash and it was missing my gestures. During this time, it always picked the volume gesture up, it was just forwarding the tracks and pausing I found difficult to register and now it's 9 times out of 10 it works.
Pretty much tried every gesture everywhere and not a single response at any stage.
Waiting for BMW Park Lane to collect the car as very obviously an issue from the factory.

Not a good start as they also delivered the car with the wrong number plate, and also forgot to apply the paint protection that was ordered in March with the original order.
__________________
Mineral White 330i M Sport Pro
Appreciate 0
      10-09-2020, 06:28 PM   #7
Keith_C
Private
Keith_C's Avatar
United Kingdom
42
Rep
86
Posts

Drives: BMW 330i M Sport Plus
Join Date: Jan 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by rodc271 View Post
Pretty much tried every gesture everywhere and not a single response at any stage.
Waiting for BMW Park Lane to collect the car as very obviously an issue from the factory.

Not a good start as they also delivered the car with the wrong number plate, and also forgot to apply the paint protection that was ordered in March with the original order.
Good luck and hope you get everything sorted, nothing worse than niggles on a new motor, especially ones as premium as these.
__________________
330i M Sport - Mineral Grey - M Sport Plus - Technology - Premium - Comfort - Visibility - Park Assistant Plus - Fine-Wood trim Oak Grain Open-Pored
Appreciate 0
      10-14-2020, 04:17 PM   #8
rodc271
Private
rodc271's Avatar
United Kingdom
17
Rep
68
Posts

Drives: Mineral White 330i M Sport Pro
Join Date: Feb 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by Keith_C View Post
Good luck and hope you get everything sorted, nothing worse than niggles on a new motor, especially ones as premium as these.
Thank. BMW have diagnosed the roof head unit (or something like that) needs replacing. Unfortunately over two weeks to get the part from Germany to the UK, a bit excessive.
__________________
Mineral White 330i M Sport Pro
Appreciate 0
      11-14-2020, 08:27 PM   #9
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by rodc271 View Post
Enabled Gesture Control in settings and no matter what gestures I try there is no response.

Tried rebooting id7 and full reset, with no change.

Car is Sep 2020 build, so all the latest software.

Any one else had similar issues?
I just took a delivery of my car, even I'm having the same problem 😳 What a great disappointment. I was really excited to try the feature, but it didn't do anything. I have to bring in for service to see whats going on.
Appreciate 0
      11-15-2020, 07:16 AM   #10
rodc271
Private
rodc271's Avatar
United Kingdom
17
Rep
68
Posts

Drives: Mineral White 330i M Sport Pro
Join Date: Feb 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by Bimmer006 View Post
Quote:
Originally Posted by rodc271 View Post
Enabled Gesture Control in settings and no matter what gestures I try there is no response.

Tried rebooting id7 and full reset, with no change.

Car is Sep 2020 build, so all the latest software.

Any one else had similar issues?
I just took a delivery of my car, even I'm having the same problem 😳 What a great disappointment. I was really excited to try the feature, but it didn't do anything. I have to bring in for service to see whats going on.
Bad news if you have the same issue.
I am still waiting for the part to be delivered from Germany after a month. They say it could be months more which is unbelievable for a car fully in production.
So disappointing to have a feature that has never worked since day one.
BMW are trying to pretend it would have worked at the pre-delivery inspection, which I don't believe.
They put the wrong number plate on the car and forgot to apply paint protection, so overall a pretty poor effort and I'm sure just never checked the car properly.
__________________
Mineral White 330i M Sport Pro
Appreciate 0
      11-15-2020, 05:03 PM   #11
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by rodc271 View Post
Bad news if you have the same issue.
I am still waiting for the part to be delivered from Germany after a month. They say it could be months more which is unbelievable for a car fully in production.
So disappointing to have a feature that has never worked since day one.
BMW are trying to pretend it would have worked at the pre-delivery inspection, which I don't believe.
They put the wrong number plate on the car and forgot to apply paint protection, so overall a pretty poor effort and I'm sure just never checked the car properly.
Its just weird, I cannot determine what's going wrong. When the bmw genius at the dealership showing all the features it worked, but when I was about to leave the dealership parking lot it did not work. When I had my genius guy inspect that, he had no clue why it's not working now, tried resetting idrive7, but that didn't help. He just told me to try tomorrow morning and if it didn't work then bring in for a technician to check.

When I tried this morning, it did work. But after a while when I turned off and turned on along with my key card, the gesture conrol stopped working. So now it's totally disabled and not working. Not sure whether something is triggering that is disabling the Gesture sensor & after few hours it's turning back on. I have to wait few hours or until tomorrow to try again. Most likely something is malfunctioning, so disappointed with a $60k car.
Appreciate 1
      11-16-2020, 06:05 PM   #12
srbs73
Second Lieutenant
srbs73's Avatar
United Kingdom
115
Rep
284
Posts

Drives: BMW M340i Touring
Join Date: Jun 2020
Location: UK

iTrader: (0)

Sounds like you have a real issue, but I definitely find you have to keep you hand further back from the screen than you think. I tend to rest my elbow on the armrest and it works 90% of the time.
Appreciate 0
      11-17-2020, 10:39 AM   #13
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by srbs73 View Post
Sounds like you have a real issue, but I definitely find you have to keep you hand further back from the screen than you think. I tend to rest my elbow on the armrest and it works 90% of the time.
Yes its just weird, I believe it has something to do with a combination of key and key card or keys. From yesterday I have been trying to use a single key as primary key and so far the Gesture control is working properly. I'll try to use my secondary key and key card on next few days to see if any of these combination is triggering the gesture sensor to turn off.
Appreciate 0
      12-07-2020, 10:01 AM   #14
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by rodc271 View Post
Bad news if you have the same issue.
I am still waiting for the part to be delivered from Germany after a month. They say it could be months more which is unbelievable for a car fully in production.
So disappointing to have a feature that has never worked since day one.
BMW are trying to pretend it would have worked at the pre-delivery inspection, which I don't believe.
They put the wrong number plate on the car and forgot to apply paint protection, so overall a pretty poor effort and I'm sure just never checked the car properly.
So finally I took my car in to the Service department on Saturday & they have figured out the Gesture sensor is malfunctioning & they have placed an order of this part for replacement. That's really ridiculous for a newly built car straight from the factory.

What is more ridiculous is that, this part they have ordered is coming from Germany (strange they don't have a warehouse in USA nor can't they get this from Mexico where the car was manufactured), so now he mentioned that it will take weeks to arrive.
Appreciate 1
srbs73114.50

      12-30-2020, 12:39 PM   #15
MJE60
Captain
MJE60's Avatar
England
483
Rep
732
Posts

Drives: BMW G01 xDrive M Sport
Join Date: Jan 2019
Location: Dorset, UK

iTrader: (0)

Quote:
Originally Posted by Bimmer006 View Post
Yes its just weird, I believe it has something to do with a combination of key and key card or keys. From yesterday I have been trying to use a single key as primary key and so far the Gesture control is working properly. I'll try to use my secondary key and key card on next few days to see if any of these combination is triggering the gesture sensor to turn off.
I took delivery of my car a couple of days ago, gesture control using guest profile worked great, then I set up my profile linked to connected drive this a.m and ..... gesture control now only works about 1 in 20 times. Clearly a software issue.
Appreciate 0
      12-30-2020, 03:22 PM   #16
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by MJE60 View Post
I took delivery of my car a couple of days ago, gesture control using guest profile worked great, then I set up my profile linked to connected drive this a.m and ..... gesture control now only works about 1 in 20 times. Clearly a software issue.
Did you try again by disconnecting your profile? At first even I thought the same, but when I did monitor few days it appeared to be the issue is not connected to the profile or software.
Appreciate 1
MJE60482.50

      12-31-2020, 07:56 AM   #17
MJE60
Captain
MJE60's Avatar
England
483
Rep
732
Posts

Drives: BMW G01 xDrive M Sport
Join Date: Jan 2019
Location: Dorset, UK

iTrader: (0)

Still early days for me but I have already noticed the problem is intermittent with no discernible pattern. Sometimes reliable and other times no response at all.

Correction, now not working at all!.

Last edited by MJE60; 01-01-2021 at 12:07 PM..
Appreciate 0
      01-23-2021, 09:46 PM   #18
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by MJE60 View Post
Still early days for me but I have already noticed the problem is intermittent with no discernible pattern. Sometimes reliable and other times no response at all.

Correction, now not working at all!.
Quote:
Originally Posted by MJE60 View Post
Still early days for me but I have already noticed the problem is intermittent with no discernible pattern. Sometimes reliable and other times no response at all.

Correction, now not working at all!.
Did you check with a dealer? I'm still waiting for my part to arrive from Germany, its been more than a month and a half.
Appreciate 0
      01-23-2021, 10:08 PM   #19
MJE60
Captain
MJE60's Avatar
England
483
Rep
732
Posts

Drives: BMW G01 xDrive M Sport
Join Date: Jan 2019
Location: Dorset, UK

iTrader: (0)

Quote:
Originally Posted by Bimmer006 View Post
Did you check with a dealer? I'm still waiting for my part to arrive from Germany, its been more than a month and a half.
Situation with my car is that the problem is 90% resolved. I found that the gesture to mute and unmute sound (two finger v sign !) works 99% of the time and once this is recognised then other gestures like increase volume, or navigate home work as well. The problem now appears to be triggered by my phone Bluetooth connection because it rarely fails when streaming directly through HU or using radio. Situation was worse in Carplay mode when gesture control appeared to totally stop working. Since then, I reset profile, deleted and re-paired the phone and I think it mainly o.k. I am getting a dealer software update on Tuesday and will see if this improves situation further.

Final point, for gesture control to work, I have to have arm resting on the arm-rest with hand approx 6 inches above gear selector. In any other position gesture control is totally useless.

Sorry to read that you are still waiting for part. I read that manufacturers reduced parts orders during shut-down and when produced resumed it increased higher than anticipated and there is a global chip shortage for car-modules because the lead time for chip production is 3 months. Hope your replacement part arrives soon.
Appreciate 0
      01-23-2021, 10:13 PM   #20
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by MJE60 View Post
Quote:
Originally Posted by Bimmer006 View Post
Did you check with a dealer? I'm still waiting for my part to arrive from Germany, its been more than a month and a half.
Situation with my car is that the problem is 90% resolved. I found that the gesture to mute and unmute sound (two finger v sign !) works 99% of the time and once this is recognised then other gestures like increase volume, or navigate home work as well. The problem now appears to be triggered by my phone Bluetooth connection because it rarely fails when streaming directly through HU or using radio. Situation was worse in Carplay mode when gesture control appeared to totally stop working. Since then, I reset profile, deleted and re-paired the phone and I think it mainly o.k. I am getting a dealer software update on Tuesday and will see if this improves situation further.

Final point, for gesture control to work, I have to have arm resting on the arm-rest with hand approx 6 inches above gear selector. In any other position gesture control is totally useless.

Sorry to read that you are still waiting for part. I read that manufacturers reduced parts orders during shut-down and when produced resumed it increased higher than anticipated and there is a global chip shortage for car-modules because the lead time for chip production is 3 months. Hope your replacement part arrives soon. I am sure I do not have a hardware problem.
Good to know you are sorting out your issue. Yes hopefully you don't have to replace any parts. I hope I'll get mine by Feb or March. Its just annoying that either Gesture control stops working or the Bass in HK sound system stops randomly during the start of the vehicle.
Appreciate 0
      01-24-2021, 05:21 AM   #21
MJE60
Captain
MJE60's Avatar
England
483
Rep
732
Posts

Drives: BMW G01 xDrive M Sport
Join Date: Jan 2019
Location: Dorset, UK

iTrader: (0)

Quote:
Originally Posted by Bimmer006 View Post
Good to know you are sorting out your issue. Yes hopefully you don't have to replace any parts. I hope I'll get mine by Feb or March. Its just annoying that either Gesture control stops working or the Bass in HK sound system stops randomly during the start of the vehicle.
Yes, I saw the G20 thread re Harman Kardon (which I also have but seems to be working o.k.).

“With the two special equipment (optional extra):
SA 6U3 BMW LIVE COCKPIT PROFESSIONAL
AND
S-0688 HARMAN / KARDON SURROUND SOUND SYSTEM
A diagnosis must be carried out in the event of a customer complaint.

If the fault memory entry in control unit RAM01:

B7F480 - Booster no connection is present and no other cause can be found: (For example loudspeaker noises or background noises originating from the end device ), the control device is:

Replace amplifier Top-Hifi-System with the following part number:
65 12 5 A38 AB8 amplifier top hi-fi system”


Given there was a bulletin re HK, are you getting the faulty amp changed also?
Appreciate 1
      01-26-2021, 01:30 PM   #22
Bimmer006
Private
19
Rep
89
Posts

Drives: BMW F30 & G20
Join Date: Oct 2020
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by MJE60 View Post
Yes, I saw the G20 thread re Harman Kardon (which I also have but seems to be working o.k.).

“With the two special equipment (optional extra):
SA 6U3 BMW LIVE COCKPIT PROFESSIONAL
AND
S-0688 HARMAN / KARDON SURROUND SOUND SYSTEM
A diagnosis must be carried out in the event of a customer complaint.

If the fault memory entry in control unit RAM01:

B7F480 - Booster no connection is present and no other cause can be found: (For example loudspeaker noises or background noises originating from the end device ), the control device is:

Replace amplifier Top-Hifi-System with the following part number:
65 12 5 A38 AB8 amplifier top hi-fi system”


Given there was a bulletin re HK, are you getting the faulty amp changed also?
Thanks for sharing this info. Even I have noticed this in the following post during the weekend. During my last service with my dealer (for Gesture control), they were trying to find out if anything is wrong in my AMP or HK system. But they couldn't find any issue. They have also told me when my Gesture control part arrives, they will try to figure out about the HK system. Fortunately for the past two months HK system is working ok, only once had the bass cut off issue, but when I restarted the car its working properly. I'll keep monitoring this and will see how it goes. I would say BMW should do a recall for this amp, if they are already saying that for the cars manufactured from March 1st, 2020 to November 1st, 2020 has this faulty amp.

https://g20.bimmerpost.com/forums/sh....php?t=1786245
Appreciate 1
MJE60482.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:43 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST