Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Technical Topics DIYs and Coding Discussions Coding More Ambient Colors And Amber Sidemarker Delete?

Post Reply
 
Thread Tools Search this Thread
      08-05-2020, 09:34 AM   #177
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Joedeejay View Post
Well I've run into an issue. When I go into expert mode on bimmercode and into 360A / 360D there is nothing in there. Blank page "No results".
That's weird. Did you update the app? Mine did that once a while back but all I needed to do was close bimmercode and then reopen it. It worked fine after.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      08-05-2020, 09:36 AM   #178
Joedeejay
Private
40
Rep
90
Posts

Drives: BMW G20
Join Date: Jan 2020
Location: UK

iTrader: (0)

Running latest version of the app ye, think it updated itself last night. Tried opening and closing etc. Just blank still. I've emailed him see what reply comes back. Gutted hah
Appreciate 0
      08-05-2020, 09:41 AM   #179
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Joedeejay View Post
Running latest version of the app ye, think it updated itself last night. Tried opening and closing etc. Just blank still. I've emailed him see what reply comes back. Gutted hah
Yes there was an update yesterday for bug fixes according to google play. But I did the coding after the update. Hopefully it fixes itself. Usually a disconnect and reconnect is all that is needed. Keep us updated.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      08-05-2020, 09:57 AM   #180
Joedeejay
Private
40
Rep
90
Posts

Drives: BMW G20
Join Date: Jan 2020
Location: UK

iTrader: (0)

Uninstall and reinstalling also done nothing. Hope it's not to do with being on 07/2020 software too
Appreciate 0
      08-05-2020, 03:04 PM   #181
andy5468
Enlisted Member
andy5468's Avatar
United Kingdom
17
Rep
47
Posts

Drives: BMW G20 320D M SPORT X DRIVE
Join Date: Aug 2009
Location: UK

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
I had some free time today to try and "decode" the three sets of hex values under 360A.

In my car, bronze has been changed to red. Bronze and white is red map spotlights/door handle & pocket lights/footwell lights and blue dash/door strips. Now the issue we had was, when the ambient light is set to the bronze white (red blue) option on the idrive, the map lights wouldn't turn on until we switched it to another color and back again. The work-around I found was to reduce the intensity of the red by a notch so that the map lights turn on as well. While it wasn't very obvious, there was a slight pinkish hue to the red and it was bothering me a wee bit (though it didn’t bother me initially). I wanted it to be pure red.
andy5468 and Joedeejay gave me an idea. Since coding became significantly faster with a wired enet cable and USB c adapter (I wouldn't have done it if I was using obdlink), I thought I'd try and decode the values. I decided to replace bytes 18,19,20, 23,24,25, 28,29,30 individually with 90,E0,90 to see which lights turned white and which stayed red.

My findings:

1. Bytes 18,19,20 - door handle and door pocket lights
2. Bytes 23,24,25 - Footwell lights
3. Bytes 28,29,30 - Map lights front and rear (small spot lights next to the dome lights)

So I replaced bytes 18,19,20 and 23,24,25 with FF,00,00 and left bytes 28,29,30 as is (FE,0A,0A). Result is pure red lights in easily visible areas (door handles, pockets, footwell) and a map light that always turns on (though with a slight pinkish hue noticeable only to me and not the others in the car since they aren't crazy like me).
Managed to get this coded tonight. Worked a treat. just did bytes 28,29,30 as recommended with the new FE,0A,0A and this fixed the issue for me too. Nice one.
Appreciate 1
VipinLJ939.00

      08-06-2020, 01:44 AM   #182
Joedeejay
Private
40
Rep
90
Posts

Drives: BMW G20
Join Date: Jan 2020
Location: UK

iTrader: (0)

Got a reply which is odd. Are you guys able to access them on latest bimmercode on Android?

"Hi,
the mapping for these groups is not available yet. This is something we are working on, but at the moment I can not tell when this will be available, sorry."

Edit just got another reply. Its a problem with latest bmw software 07/2020. Damn you android auto

Last edited by Joedeejay; 08-06-2020 at 01:54 AM..
Appreciate 0
      08-06-2020, 01:54 AM   #183
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by Joedeejay View Post
Got a reply which is odd. Are you guys able to access them on latest bimmercode on Android?

"Hi,
the mapping for these groups is not available yet. This is something we are working on, but at the moment I can not tell when this will be available, sorry."
Mine got an update on the 3rd (3 days ago). I did the coding on the 4th. No updates after that. Bimmercode for Android, version 2.26.2-6781 (beta tester).
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      08-06-2020, 02:33 AM   #184
Joedeejay
Private
40
Rep
90
Posts

Drives: BMW G20
Join Date: Jan 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
Mine got an update on the 3rd (3 days ago). I did the coding on the 4th. No updates after that. Bimmercode for Android, version 2.26.2-6781 (beta tester).
Unfortunately its the cars software that's at fault! 07/2020 latest version. Said a fix is in the pipeline but no idea when.
Appreciate 0
      08-08-2020, 10:08 AM   #185
mmo011
New Member
0
Rep
6
Posts

Drives: BMW 320d MSport (G20)
Join Date: Apr 2020
Location: Italy

iTrader: (0)

Anybody tested to code the real M Color Scheme instead using pure colors like RED #FF0000?
here below the HEX for the right colors:

https://www.schemecolor.com/bmw-m.php

Name: Light Sky Blue
Hex: #81C4FF

Name: Yale Blue
Hex: #16588E

Name: Alizarin Crimson
Hex: #E7222E
Appreciate 0
      08-08-2020, 12:56 PM   #186
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by mmo011 View Post
Anybody tested to code the real M Color Scheme instead using pure colors like RED #FF0000?
here below the HEX for the right colors:

https://www.schemecolor.com/bmw-m.php

Name: Light Sky Blue
Hex: #81C4FF

Name: Yale Blue
Hex: #16588E

Name: Alizarin Crimson
Hex: #E7222E
I tried using E7222E before I used FE0A0A and it looked like a pink. Definitely didn't look like red. Which was why I searched for something closer to red and got FE0A0A.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      08-10-2020, 02:35 PM   #187
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
I had some free time today to try and "decode" the three sets of hex values under 360A.

In my car, bronze has been changed to red. Bronze and white is red map spotlights/door handle & pocket lights/footwell lights and blue dash/door strips. Now the issue we had was, when the ambient light is set to the bronze white (red blue) option on the idrive, the map lights wouldn't turn on until we switched it to another color and back again. The work-around I found was to reduce the intensity of the red by a notch so that the map lights turn on as well. While it wasn't very obvious, there was a slight pinkish hue to the red and it was bothering me a wee bit (though it didn't bother me initially). I wanted it to be pure red.
andy5468 and Joedeejay gave me an idea. Since coding became significantly faster with a wired enet cable and USB c adapter (I wouldn't have done it if I was using obdlink), I thought I'd try and decode the values. I decided to replace bytes 18,19,20, 23,24,25, 28,29,30 individually with 90,E0,90 to see which lights turned white and which stayed red.

My findings:

1. Bytes 18,19,20 - door handle and door pocket lights
2. Bytes 23,24,25 - Footwell lights
3. Bytes 28,29,30 - Map lights front and rear (small spot lights next to the dome lights)

So I replaced bytes 18,19,20 and 23,24,25 with FF,00,00 and left bytes 28,29,30 as is (FE,0A,0A). Result is pure red lights in easily visible areas (door handles, pockets, footwell) and a map light that always turns on (though with a slight pinkish hue noticeable only to me and not the others in the car since they aren't crazy like me).
Nice catch. I can confirm that ANY of the three colors (RGB) set to FF with all 0000 in the other bytes results in the built in ambient lighting on the roof function module not working until switching colors.

I was able to replicate the issue with 00FF00 and 0000FF for the other solid / non mixed colors.
Appreciate 1
VipinLJ939.00

      08-10-2020, 04:46 PM   #188
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
Quote:
Originally Posted by VipinLJ View Post
I had some free time today to try and "decode" the three sets of hex values under 360A.

In my car, bronze has been changed to red. Bronze and white is red map spotlights/door handle & pocket lights/footwell lights and blue dash/door strips. Now the issue we had was, when the ambient light is set to the bronze white (red blue) option on the idrive, the map lights wouldn't turn on until we switched it to another color and back again. The work-around I found was to reduce the intensity of the red by a notch so that the map lights turn on as well. While it wasn't very obvious, there was a slight pinkish hue to the red and it was bothering me a wee bit (though it didn't bother me initially). I wanted it to be pure red.
andy5468 and Joedeejay gave me an idea. Since coding became significantly faster with a wired enet cable and USB c adapter (I wouldn't have done it if I was using obdlink), I thought I'd try and decode the values. I decided to replace bytes 18,19,20, 23,24,25, 28,29,30 individually with 90,E0,90 to see which lights turned white and which stayed red.

My findings:

1. Bytes 18,19,20 - door handle and door pocket lights
2. Bytes 23,24,25 - Footwell lights
3. Bytes 28,29,30 - Map lights front and rear (small spot lights next to the dome lights)

So I replaced bytes 18,19,20 and 23,24,25 with FF,00,00 and left bytes 28,29,30 as is (FE,0A,0A). Result is pure red lights in easily visible areas (door handles, pockets, footwell) and a map light that always turns on (though with a slight pinkish hue noticeable only to me and not the others in the car since they aren't crazy like me).
Nice catch. I can confirm that ANY of the three colors (RGB) set to FF with all 0000 in the other bytes results in the built in ambient lighting on the roof function module not working until switching colors.

I was able to replicate the issue with 00FF00 and 0000FF for the other solid / non mixed colors.
Strange bug since red / green / blue look better at the full value. I have this issue on most of my presets as I changed base colors to full values across the board.
Appreciate 0
      08-29-2020, 09:01 PM   #189
tturbolife
Captain
tturbolife's Avatar
United_States
181
Rep
996
Posts

Drives: 2020 M340i, 2009 650i
Join Date: May 2013
Location: USA

iTrader: (1)

Garage List
2020 BMW M340i  [0.00]
Thanks for the values to fix the overhead LED issue. I replaced green with red and green/white with green/blue.

360A:
Red/Blue:
Default Green (10,FE,32) at bytes:
63,64,65 -> FF,00,00
68,69,70 -> FF, 00, 00
73,74,75 -> FE, 0A, 0A

360D:
Red/Blue:
Byte 17: 00 —> 03
(This changes the white (00) in Green/White to Blue (03))
__________________
M340i: Arctic White, 790M wheels, Cognac interior, Aluminum Tetragon trim
Appreciate 0
      09-01-2020, 01:51 PM   #190
dominguez255
Enlisted Member
3
Rep
30
Posts

Drives: BMW Serie 1 F40
Join Date: Aug 2020
Location: Valladolid, España

iTrader: (0)

Two issues:

1- Is it possible to change the name and color that appears on the idrive display? bronze to red, the real ambient color has already changed and it works.

2- Is it possible to turn on the underfoot light that comes on when the doors are opened, using coding?
Appreciate 0
      09-01-2020, 07:00 PM   #191
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by dominguez255 View Post
Two issues:

1- Is it possible to change the name and color that appears on the idrive display? bronze to red, the real ambient color has already changed and it works.

2- Is it possible to turn on the underfoot light that comes on when the doors are opened, using coding?
1. So far no one has been able to figure out how to change the color names on the idrive in any of the cars (3 series, X3, X5 etc).

2. Which underfoot lighting? Do you mean the light in the footwells?
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      09-02-2020, 03:39 AM   #192
dominguez255
Enlisted Member
3
Rep
30
Posts

Drives: BMW Serie 1 F40
Join Date: Aug 2020
Location: Valladolid, España

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
1. So far no one has been able to figure out how to change the color names on the idrive in any of the cars (3 series, X3, X5 etc).

2. Which underfoot lighting? Do you mean the light in the footwells?

Yes the light in the footwells
Appreciate 0
      09-02-2020, 08:45 AM   #193
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

Quote:
Originally Posted by dominguez255 View Post
Yes the light in the footwells
Are they not on for you? In my car, when the ambient lights are on, the footwell lights are also on, in the corresponding color. When I open a door, the footwell light turns to white.
I think that’s how it is supposed to work?
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      09-02-2020, 12:24 PM   #194
dominguez255
Enlisted Member
3
Rep
30
Posts

Drives: BMW Serie 1 F40
Join Date: Aug 2020
Location: Valladolid, España

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
Are they not on for you? In my car, when the ambient lights are on, the footwell lights are also on, in the corresponding color. When I open a door, the footwell light turns to white.
I think that’s how it is supposed to work?
The problem is that my car is 118i F40 not G20, but i think that we can coding this option, all is code in this cars.
Appreciate 0
      09-22-2020, 04:40 AM   #195
takky
New Member
takky's Avatar
Thailand
3
Rep
5
Posts

Drives: 330e G20
Join Date: Apr 2020
Location: BKK, Thailand

iTrader: (0)

Quote:
Originally Posted by Joedeejay View Post
Well I've run into an issue. When I go into expert mode on bimmercode and into 360A / 360D there is nothing in there. Blank page "No results".
Mine was the same, after my car was updated software to 07/2020.48
Appreciate 1
      09-28-2020, 11:22 PM   #196
tturbolife
Captain
tturbolife's Avatar
United_States
181
Rep
996
Posts

Drives: 2020 M340i, 2009 650i
Join Date: May 2013
Location: USA

iTrader: (1)

Garage List
2020 BMW M340i  [0.00]
Quote:
Originally Posted by takky View Post
Quote:
Originally Posted by Joedeejay View Post
Well I've run into an issue. When I go into expert mode on bimmercode and into 360A / 360D there is nothing in there. Blank page "No results".
Mine was the same, after my car was updated software to 07/2020.48
Same... I hope BMW didn't lock us out
__________________
M340i: Arctic White, 790M wheels, Cognac interior, Aluminum Tetragon trim
Appreciate 0
      09-29-2020, 11:26 AM   #197
VipinLJ
Petrolhead
VipinLJ's Avatar
United_States
939
Rep
2,088
Posts

Drives: ‘20 330i,‘16 X3,‘18 SQ5,‘17 A7
Join Date: Nov 2019
Location: Illinois

iTrader: (2)

I'm on 07.2019.38 and I used bimmercode yesterday. I could access all modules without any issues.
__________________
Current:
2020 BMW 330i xDrive
2018 Audi SQ5 Prestige
2017 Audi A7 Prestige
Appreciate 0
      10-01-2020, 04:30 AM   #198
Joedeejay
Private
40
Rep
90
Posts

Drives: BMW G20
Join Date: Jan 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by VipinLJ View Post
I'm on 07.2019.38 and I used bimmercode yesterday. I could access all modules without any issues.
The issue is with 07.2020 software mate, you are on last July 2019 which is fine

From Bimmercode

The Android version will receive an update as soon as the mapping is available.

Kind regards / Schöne Grüße
Stephan Gauch
Appreciate 1
VipinLJ939.00

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:20 AM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST