Bimmerpost
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Technical Topics iDrive, Nav, Phone, Audio, Video, Cameras, Electronics CarPlay issues

Post Reply
 
Thread Tools Search this Thread
      05-26-2019, 07:00 PM   #1
Lemuecg20
New Member
0
Rep
10
Posts

Drives: BMW 330i M sport
Join Date: Apr 2019
Location: Wiesbaden, Germany

iTrader: (0)

CarPlay issues

Has anybody have issues connecting their iPhones to use CarPlay? My phone finds my 330i but I donít know what else to do to get my apps to show on the screen. Any help will be appreciated.
Appreciate 0
      05-26-2019, 09:02 PM   #2
CyclingBroStyle
Private First Class
CyclingBroStyle's Avatar
United_States
54
Rep
133
Posts

Drives: '19 330i xDrive M Sport
Join Date: Sep 2014
Location: Washington, D.C.

iTrader: (0)

Garage List
Delete device from car. Forget from phone. Re pair. Accept CarPlay on phone and car. Also under Mobile devices make sure WiFi is on
__________________
Current: MY2019 330i xDrive M-Sport w/Lasers - Portimao Blue
Previous: MY2013 328i xDrive Sport Line - Sapphire Black | MY2016 428i xDrive M-Sport - Mineral Grey
BMW CCA #522637 use me as a referral for BMW CCA
Appreciate 1
      05-27-2019, 02:08 AM   #3
Xsapper
Private First Class
Xsapper's Avatar
United Kingdom
51
Rep
188
Posts

Drives: G20 330i M Sport
Join Date: Feb 2009
Location: Monmouth, UK

iTrader: (0)

Garage List
I also have 'bluetooth' switched on my phone but not sure if required but worth a try
Appreciate 0
      05-27-2019, 02:15 AM   #4
Wodzu
New Member
5
Rep
14
Posts

Drives: BMW G20 330i / BMW F30 318d
Join Date: May 2019
Location: Poland

iTrader: (0)

So, waiting for my 330i to pop out, I have been given with a fully equipped (M sport, executive package, HK, all the driving assistants, etc.) 320D xDrive for a weekend and had a chance to give it a 450 kilometers test drive. I found it superb and a great improvement over F30 (which I will replace with g20 330i within next month). One thing however which seemed not to work that flawlessly was the Bluetooth iPhone integration. The connection (iDrive as well as CarPlay modes) was dropped several times. I had to reboot the phone in order to reconnect, play with Bt, Wifi settings, delete the phone and reconnect it a couple of times. So I guess its not that rare issue.
Appreciate 1
      05-27-2019, 05:31 AM   #5
DomiGijzen
Private
DomiGijzen's Avatar
Netherlands
13
Rep
63
Posts

Drives: BMW 320d (G20)
Join Date: Apr 2019
Location: Netherlands

iTrader: (0)

I wonder, what version of iOS do you use? I read somewhere that updating from 12.2 to 12.3 solves some issues. Did it and had no drop outs this morning. 1hr drive.
__________________
Grz D.!
Appreciate 1
      05-27-2019, 08:35 AM   #6
Lemuecg20
New Member
0
Rep
10
Posts

Drives: BMW 330i M sport
Join Date: Apr 2019
Location: Wiesbaden, Germany

iTrader: (0)

Quote:
Originally Posted by CyclingBroStyle View Post
Delete device from car. Forget from phone. Re pair. Accept CarPlay on phone and car. Also under Mobile devices make sure WiFi is on
I did it but the accept CarPlay option doesnít show 🤷🏽*♂️. I donít even know what to do next 🤬
Appreciate 0
      05-27-2019, 11:44 AM   #7
Lemuecg20
New Member
0
Rep
10
Posts

Drives: BMW 330i M sport
Join Date: Apr 2019
Location: Wiesbaden, Germany

iTrader: (0)

Quote:
Originally Posted by DomiGijzen View Post
I wonder, what version of iOS do you use? I read somewhere that updating from 12.2 to 12.3 solves some issues. Did it and had no drop outs this morning. 1hr drive.
I just updated my phone with the latest and greatest version. CarPlay is nowhere to be found in my settings 🤷🏽*♂️
Appreciate 0
      05-27-2019, 12:59 PM   #8
Uoflfan27
New Member
6
Rep
25
Posts

Drives: 2014 335xi
Join Date: Sep 2017
Location: USA

iTrader: (0)

Quote:
Originally Posted by Lemuecg20 View Post
Quote:
Originally Posted by DomiGijzen View Post
I wonder, what version of iOS do you use? I read somewhere that updating from 12.2 to 12.3 solves some issues. Did it and had no drop outs this morning. 1hr drive.
I just updated my phone with the latest and greatest version. CarPlay is nowhere to be found in my settings 🤷🏽*♂️
It's not in settings and then general? 5th option down
Appreciate 0
      05-27-2019, 04:42 PM   #9
CrownRoyal79
Private First Class
106
Rep
135
Posts

Drives: BMW 435i
Join Date: Mar 2019
Location: VA

iTrader: (0)

Quote:
Originally Posted by Uoflfan27 View Post
Quote:
Originally Posted by Lemuecg20 View Post
Quote:
Originally Posted by DomiGijzen View Post
I wonder, what version of iOS do you use? I read somewhere that updating from 12.2 to 12.3 solves some issues. Did it and had no drop outs this morning. 1hr drive.
I just updated my phone with the latest and greatest version. CarPlay is nowhere to be found in my settings 🤷🏽*♂️
It's not in settings and then general? 5th option down
CarPlay is great when it works but it's really flaky. For example, I get in my car and start it up, CarPlay connects just fine. But if I say "hey bmw, take me.... (insert destination) CarPlay completely disconnects a few moments later. Is this expected? Am I forced to use my phone's GPS to keep CarPlay connected? Even if I cancel the route through BMW, CarPlay will not reconnect until I restart the car.
Appreciate 1
      05-27-2019, 08:41 PM   #10
Cosmo_Kramer
Private First Class
42
Rep
115
Posts

Drives: Lexus
Join Date: Apr 2019
Location: California

iTrader: (0)

Quote:
Originally Posted by CrownRoyal79 View Post
CarPlay is great when it works but it's really flaky. For example, I get in my car and start it up, CarPlay connects just fine. But if I say "hey bmw, take me.... (insert destination) CarPlay completely disconnects a few moments later. Is this expected? Am I forced to use my phone's GPS to keep CarPlay connected? Even if I cancel the route through BMW, CarPlay will not reconnect until I restart the car.
I really hope BMW will get their act together and fix this issue or update software to allow wired CarPlay. Does BMW expect people to pay $80 a year for broken CarPlay? I havenít heard any other car makers charging for subscription and have it not working.

Iím getting my car in a few weeks having CarPlay was one of the major decisions to get this car. Maybe I should just bail out on my order.
Appreciate 1
      05-27-2019, 10:31 PM   #11
pneumodoc
Enlisted Member
pneumodoc's Avatar
20
Rep
41
Posts

Drives: 330i
Join Date: Apr 2019
Location: Seattle

iTrader: (0)

Quote:
Originally Posted by Cosmo_Kramer View Post
I really hope BMW will get their act together and fix this issue or update software to allow wired CarPlay. Does BMW expect people to pay $80 a year for broken CarPlay? I havenít heard any other car makers charging for subscription and have it not working.

Iím getting my car in a few weeks having CarPlay was one of the major decisions to get this car. Maybe I should just bail out on my order.
I switched to using bluetooth for the time being, since Carplay was so bad. Hopefully with the next firmware update..
Appreciate 0
      05-30-2019, 12:18 PM   #12
Lrscpa
First Lieutenant
Lrscpa's Avatar
United_States
48
Rep
327
Posts

Drives: '16 640xi Gran Coupe
Join Date: Jan 2007
Location: New Jersey

iTrader: (0)

I've had CarPlay in rental cars (mostly Chevys) for a couple of years now. Has worked flawlessly there.

I have a 330i on order - odd that the only car manufacturer that charges for CarPlay would have so many issues.
__________________
2019 G20 330i xDrive Med. Blue/Cognac Leather ZCV|ZPP|ZPX|HK|Remote Start (On Order)
2016 F06 640i xDrive Med. Blue/Red Leather MSport Edition|B&O|Driver Asst+|Cold|Night
2013 F30 335i xDrive Mineral Grey/Black Leather (Retired)
2011 E90 328i xDrive Space Grey/Black Leather(Retired)
2009 E90 328i xDrive Monaco Blue/(Retired) 2007 E90 328i xDrive Graphite (Retired)
Appreciate 0
      05-30-2019, 01:41 PM   #13
Donia330i
Major
Donia330i's Avatar
United_States
72
Rep
1,239
Posts

Drives: 19 330i BSM
Join Date: Feb 2009
Location: Atlanta, GA

iTrader: (7)

I have the same issue. Switched it off for now. Has anyone spoken to a SA about it yet?
Appreciate 0
      05-30-2019, 02:05 PM   #14
ferbmw
Private
5
Rep
62
Posts

Drives: BMW 330i G20 2019 Sportline
Join Date: Mar 2017
Location: Buenos Aires, Argentina

iTrader: (0)

I recently purchased the new 3 Series g20. Wonderful car.
However I am having a problem with the app waze in apple car play.
As far as I know apple car play uses wifi to connect withe the vehicle.
The problem is the waze app turns the map randomly and losses the route selected starting again from the point/strett where the map turns itself. Other symptom is the map turns upside down and sometimes is like the car is moving backwards in the map.

Has anybody experienced this? Solutions? Update for the firmware? Connecting with usb seems not to be possible, only wifi for using apple car play.

By the way, when I disconnect the iphone from the car the app works perfectly with no bugs.

Thanks for your help
Appreciate 0
      06-10-2019, 08:02 AM   #15
westox
Registered
United_States
0
Rep
3
Posts

Drives: 2019 BMW 330 X Drive
Join Date: Jun 2019
Location: Midwest

iTrader: (0)

I recently got the new G20. The first day I played with the bluetooth and tried to connect carplay it worked for couple hours and disconnected afterwards. Now I tried to reconnect over the com->mobile device and the idrive system will freeze after I tried to add a device or delete the current device. In another words, the bluetooth is not responsive at all.

Any one knows a possible solution to reset the bluetooth system of idrive? Or how to reboot the idrive system? I believe mine is in version 7.0. I tried to turn off the car, locked, turn on and it still gives me the same bluetooth issue. There seems to be a bug of it.

Thank you for your help.
Appreciate 0
      06-12-2019, 06:47 PM   #16
pneumodoc
Enlisted Member
pneumodoc's Avatar
20
Rep
41
Posts

Drives: 330i
Join Date: Apr 2019
Location: Seattle

iTrader: (0)

So one of the BMWNA reps called me to check in about the car (which is a nice touch that I didn't think they would do). I told them about the only real issue I've had being the apple CarPlay. They acknowledged the issues, and said that I should try deleting my phone from the car and delete my car from apple CarPlay in my phone. After doing that, try re-pairing. They said that may need to be done whenever iOS updates. I tried it.

It didn't work. Oh well. Will wait til iDrive updates, and then try again. Bluetooth for me until then, which is sort of a bummer.
Appreciate 0
      06-13-2019, 07:18 AM   #17
ferbmw
Private
5
Rep
62
Posts

Drives: BMW 330i G20 2019 Sportline
Join Date: Mar 2017
Location: Buenos Aires, Argentina

iTrader: (0)

Yesterday I traveled with a friend in a Jeep Compass with APC. None of the bugs described here appeared on this car. How can BMW be have so many problems with APC? Are the other makers genius in IT or the IT guys from BMW are simply narrowminded? Cannot believe a luxury?? car has so many issues
Appreciate 0
      06-13-2019, 07:52 PM   #18
mzdial
Private First Class
mzdial's Avatar
United_States
32
Rep
118
Posts

Drives: '19 G20 330i & '19 G01 X3
Join Date: Oct 2013
Location: Zionsville, IN

iTrader: (0)

Garage List
Quote:
Originally Posted by westox View Post
Any one knows a possible solution to reset the bluetooth system of idrive? Or how to reboot the idrive system? I believe mine is in version 7.0. I tried to turn off the car, locked, turn on and it still gives me the same bluetooth issue. There seems to be a bug of it.
I've been having problems with ConnectedDrive (which I'm figuring out is wide spread, but BMW doesn't want to admit it.) Here was what they suggested for me to update, restart. The pressing and holding of the volume button for an extended period has been the method for many generations now, for what it's worth.

- Via the iDrive "Apps"
- You will see a grey screen with the choice to either select Installed Apps or the BMW Store. Select neither option.
- Press the OPTION button near your iDrive controller.
- Select "Update Installed Apps and Services."
- After the update is complete, select "Close."
- Activate a sleep cycle in your vehicle by pressing and holding the mute (VOL) button for 30-45 seconds with the car on but parked.
Appreciate 1
      06-15-2019, 09:45 AM   #19
Antkn33
New Member
6
Rep
28
Posts

Drives: 2020 M340i xdrive
Join Date: Jun 2019
Location: Michigan

iTrader: (0)

Mine connects about half the time. It seems itís beca my phone is still connected to my homes wifi when I start the car. If I manually connect to the cars wifi and disconnect/ re- connect the phone in idrive CarPlay works.
Seems like an obvious problem that bmw should have known about.
Appreciate 1
      06-15-2019, 12:22 PM   #20
phillyd2
Second Lieutenant
74
Rep
238
Posts

Drives: 2020 M340i XDrive
Join Date: May 2012
Location: SE, PA

iTrader: (0)

Mine connects all of the time without issue but then the car / phone lose connection. It tries to reconnect but usually fails. On the next start up it's connected again.

I'm using a iPhone X with the everything up to date.
Appreciate 0
      06-15-2019, 01:23 PM   #21
claykin
Colonel
United_States
294
Rep
2,647
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by phillyd2 View Post
Mine connects all of the time without issue but then the car / phone lose connection. It tries to reconnect but usually fails. On the next start up it's connected again.

I'm using a iPhone X with the everything up to date.
Program one of the physical radio presets to toggle Bluetooth on/off. When it disconnects next, toggle Bluetooth off then back on. That should prompt a reconnect to phone.

Clearly BMW has OS and/or Bluetooth driver issues they need to resolve. That said, Bluetooth is a pretty crap technology to begin with and it's rarely trouble free. Even previous generations of iDrive has their fair share of issues. Probably not as bad as iDrive 7 is dealing with now, but they've had them.
__________________
2016 535i MSport | 2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 3
      06-15-2019, 01:33 PM   #22
phillyd2
Second Lieutenant
74
Rep
238
Posts

Drives: 2020 M340i XDrive
Join Date: May 2012
Location: SE, PA

iTrader: (0)

Quote:
Originally Posted by claykin View Post
Program one of the physical radio presets to toggle Bluetooth on/off. When it disconnects next, toggle Bluetooth off then back on. That should prompt a reconnect to phone.

Clearly BMW has OS and/or Bluetooth driver issues they need to resolve. That said, Bluetooth is a pretty crap technology to begin with and it's rarely trouble free. Even previous generations of iDrive has their fair share of issues. Probably not as bad as iDrive 7 is dealing with now, but they've had them.
Just Programmed one and will try next time it disconnects. Thanks.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:22 PM.




g20
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST